模拟队列


题目

实现一个队列,队列初始为空,支持四种操作:
(1) “push x” – 向队尾插入一个数x;
(2) “pop” – 从队头弹出一个数;
(3) “empty” – 判断队列是否为空;
(4) “query” – 查询队头元素。
现在要对队列进行M个操作,其中的每个操作3和操作4都要输出相应的结果。
输入格式
第一行包含整数M,表示操作次数。
接下来M行,每行包含一个操作命令,操作命令为”push x”,”pop”,”empty”,”query”中的一种。
输出格式
对于每个”empty”和”query”操作都要输出一个查询结果,每个结果占一行。
其中,”empty”操作的查询结果为“YES”或“NO”,”query”操作的查询结果为一个整数,表示队头元素的值。
数据范围
1≤M≤100000,1≤x≤109,所有操作保证合法。
输入样例:
10
push 6
empty
query
pop
empty
push 3
push 4
pop
query
push 6
输出样例:
NO
6
YES
4

4

#include<iostream>
#include<algorithm>
using namespace std;
int aa[123456];
int hh=0,tt=0;
void queue_push(int x)
{  //向队列里加入元素,是要在队尾加入
    aa[tt++]=x;
}
void queue_pop()
{ //因为队列是先进先出,所以要hh++
    hh++;
}
void queue_empty()
{
    if(hh>=tt) cout<<"YES"<<endl;
    else cout<<"NO"<<endl;
}
void queue_query()
{  //输出队头
    cout<<aa[hh]<<endl;
}
int main()
{
    int n;
    cin>>n;
    while(n--)
    {
        string s;
        cin>>s;
        if(s=="push") 
        {
            int x;
            cin>>x;
            queue_push(x);
        }
        else if(s=="pop") queue_pop();
        else if(s=="empty") queue_empty();
        else if(s=="query") queue_query();
    }
    return 0;
}
​```

Author: 眼里有星星
Reprint policy: All articles in this blog are used except for special statements CC BY 4.0 reprint polocy. If reproduced, please indicate source 眼里有星星 !
 Previous
最大异或对 最大异或对
题目在给定的N个整数A1,A2……AN中选出两个进行xor(异或)运算,得到的结果最大是多少?输入格式第一行输入一个整数N。第二行输入N个整数A1~AN。输出格式输出一个整数表示答案。数据范围1≤N≤105,0≤Ai<231输入样例:
2020-02-22
Next 
堆排序 堆排序
题目输入一个长度为n的整数数列,从小到大输出前m小的数。输入格式第一行包含整数n和m。第二行包含n个整数,表示整数数列。输出格式共一行,包含m个整数,表示整数数列中前m小的数。数据范围1≤m≤n≤10 ^ 5,1≤数列中元素≤10 ^ 9输
2020-02-22
  TOC