题目
给定两个正整数,计算它们的和。
输入格式
共两行,每行包含一个整数。
输出格式
共一行,包含所求的和。
数据范围
1≤整数长度≤100000
输入样例:
12
23
输出样例:
35
代码
#include<iostream>
#include<cstring>
using namespace std;
int sc[1234567];
int main()
{
string sa,sb;
cin>>sa>>sb;
int lena=sa.length();int lenb=sb.length();
int temp=0;int i,j,k=0;
for(i=lena-1,j=lenb-1;i>=0&&j>=0;i--,j--)
{
temp=sa[i]-'0'+sb[j]-'0'+temp;
sc[k++]=temp%10;
temp=temp/10;
}
while(i>=0)
{
temp=temp+sa[i]-'0';
sc[k++]=temp%10;
temp=temp/10;
i--;
}
while(j>=0)
{
temp=temp+sb[j]-'0';
sc[k++]=temp%10;
temp=temp/10;
j--;
}
if(temp) sc[k++]=temp;
for(int g=k-1;g>=0;g--) cout<<sc[g];
cout<<endl;
return 0;
}